VLAN bridge на Mikrotik - TRUNK и ACCESS порты

Стоит заметить, что существует не один способ организации VLAN трафика на Mikrotik. Но только один из этих способов конфигурации VLAN является наиболее корректным, позволяющим исключить проблемы с производительностью и подключением.

Начиная с версии RouterOS 6.41 стало возможно использовать мост для фильтрации VLAN и именно эта конфигурация рекомендована официальным Wiki Mikrotik.

Рассмотрим базовую конфигурацию VLAN позволяющую разделить локальную сеть на два виртуальных сегмента для разных отделов офиса.

Ether1 - это trunk-порт, VLAN20 и VLAN30
Ether2 - access-порт VLAN20
Ether3 - access-порт VLAN30

Базовая схема коммутации VLAN
Базовая схема коммутации VLAN

Для начала нам необходимо создать мост bidge1 с фильтрацией VLAN. Для включение фильтрации VLAN перейдите во вкладку VLAN и отметьте пункт "VLAN Filtering".

мост с фильтрацией VLAN
Мост с фильтрацией VLAN

В статье я буду приводить примеры настроек как для графического интерфейса так и для консоли.

interface bridge add name=bridge1 vlan-filtering=yes

Добавляем порты в мост bidge1 и назначаем им PVID.

PVID (Port VLAN ID) - используется для ACCESS-портов и маркирует весь входящий трафик соответствующим VLAN ID. Поэтому для порта Ether1 PVID не назначаем т.к. он является tunk-портом и передает tagged-трафик

Добавление access порта с PVID в bridge
Добавление access порта с PVID в bridge
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2 pvid=20
add bridge=bridge1 interface=ether3 pvid=30

Добавляем соответствующие записи в VLAN таблицу моста.

  • Для VLAN20 в качестве порта передающего тегированный трафик выбираем Ether1 (trunk), порт для нетегированного трафика Ether2 (access).
  • VLAN30 для тегированного трафика так же Ether1 (trunk), нетегированный - Ether3 (access).
VLAN таблица моста
VLAN таблица моста
/interface bridge vlan
add bridge=bridge1 tagged=ether1 untagged=ether2 vlan-ids=20
add bridge=bridge1 tagged=ether1 untagged=ether3 vlan-ids=30

В случае работающей VLAN фильтрации на bridge таблица VLAN выглядит примерно так:

[admin@MikroTik] > /interface bridge vlan print
Flags: X - disabled, D - dynamic 
 #   BRIDGE                     VLAN-IDS  CURRENT-TAGGED       CURRENT-UNTAGGED                                                      
 0   bridge1                    20        ether1               ether2                                                                
 1   bridge1                    30        ether1               ether3                                                                
 2 D bridge1                    1                              bridge1                                                                
                                                               ether1

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *